segunda-feira, junho 20, 2005

Mad Max Real



Eu temo por isso. Não como no filme mas em algo parecido. Há cerca de 3 anos atrás que deparei pela primeira vez com ceticismo e descrédito nesse assunto controverso da área de energia. Tentei contradizê-lo várias vezes. A questão é conhecida pelo termo Peak Oil, ou no português como 'Pico Petrolífero'. Um dia ocorrerá em menos de 50 anos trará consequências devastadoras se não forem tomadas medidas que venham nos preparar para esse evento gradual. O problema maior está na produção de fertilizantes e defensivos agrícolas que permitiram sobrepujar a teoria prevista por Thomas Malthus. Praticamente toda a produção agrícola atual é extremamente dependente no petróleo, desde o uso de fertilizantes, uso de defensivos agrícolas para dirimir pragas, colheita, transporte para grandes centros. E para os dois primeiros não existe ainda método que substitua a produção, na pior das hipóteses podemos usar o carvão mas seu processamento para substituir os derivados do petróleo são caros e poluentes. E ele inclusive tem seu "Peak Coal" mais distante. Usar carvão vegetal? Tem baixíssimo rendimento. GNV? Peak Gas também existe. Biodiesel? Haja área de plantio para substituir toda a demanda de diesel. Mas quem sabe? Posso estar enganado, óleo de mamona? Que nasce e cresce em qualquer lugar?
Duro mesmo vai ser substituir toda a frota de automóveis particulares a gasolina para usar outro combustível. Transformar de o motor a gasolina para álcool ou GNV não requer modificações extremas como acontece com o diesel, que inclusive é conhecido como ciclo diesel por ser tão diferente do ciclo Otto ( gasolina, álcool e GNV )

O primeiro estudioso do tema foi conhecido como Marion King Hubbert, um geólogo americano que trabalhou na Shell e foi pesquisador da USGS ( United States Geological Survey ). Ele previu que o pico petrolífero dos poços dos EUA ocorreria na década de 1970 e divulgou isso em um paper em meados de 1956. Foi contrariado por quase todos seus pares. Até que em 1970, durante a crise do petróleo de 1973 percebeu-se que a sua previsão foi real e mostrou-se correta. De demônio passou a ser rei, e reconhecido. M.K.Hubbert faleceu em 11 de outubro de 1989 com 86 anos. Uma breve biografia aqui.

Falta o pico petrolífero do mundo, oficialmente ainda distante de 30 a 40 anos, mas usando-se a teoria de Hubbert o pico está previsto para esta década, antes de 2010. E essa previsão é cercada de muita controvérsia, uma vez que dados reais dos poços do Oriente Médio e da Rússia sempre foram indisponíveis por se tratar de um dados estratégicos.
A produção atual é de cerca de 85 milhões de barris/dia, os EUA consomem sozinho um quarto disso. O Brasil consome dois milhões/dia com a Petrobás sendo quase ou já auto-suficiente. Entretanto nossos poços também tem seu Peak Oil. Veja aqui um breve relato da Associação de Engenheiros da Petrobrás.

Mesmo que o Peak Oil não venha como um choque no mundo, ela ocorrerá em algum momento de nossas vidas, nessa primeira metade desse século. Melhor prevenir do que remediar. Energia Solar, Eólica, Nuclear ou qualquer outro que venha a ser descoberto dificilmente substituirá o ouro negro no setor agrícola. Se o 'worst case scenario' vir a acontecer, a 'Fome Zero' ficará ainda mais distante.

Um problema crescente e incerta é a folga que a OPEP pode ter de oferta diária, aliada às pressões crescentes de consumo pela China e Índia consequência dos respectivos crescimentos econômicos.

Prever o futuro é uma ciência nebulosa e complicada, cheia de variáveis. Muitos consideram o Peak Oil um grande SCAM da indústria petrolífera, outros dizem que a Guerra do Iraque teve como pano de fundo esse problema, com uma possível 'crise de oferta' do óleo, vai lá saber.

Hoje verifiquei que o barril estava cotado a US$58/barril na sexta-feira. :(

Precisamos de OILIX, precisamos de um Dr.Kio Marv. Faz-me lembrar do jogo Metal Gear2 Solid Snake do MSX, que tratava disso, um jogo de um computador de 8bits antigo, mas muito bom. Pena que OILIX seja ficção.

sábado, junho 18, 2005

Pentium 4 3.4GHz Northwood


Estou editando esse blog agora num PC com esse processador! Foi a primeira vez que fiz manutenção em um micro P4, e até agora, depois do conserto ( troca de placa-mãe ) estou fazendo alguns testes de estabilidade e rodando distributed.netc em background, não é a melhor opção mas serve para "esquentar" o processador para ver até onde chega.

Bom vou começar do princípio. Eu e um amigo meu recebemos um pedido da prima dele ( que está no exterior ) onde um conhecido dela estava tendo problemas com um computador. A única informação que ouvimos foi que um raio danificou e o computador parou de funcionar. Até aí passou um mooonte de possibilidades na minha cabeça.

Ficamos de receber o computador via correio, o que nunca ocorreu, talvez insegurança do proprietário, não tiro a razão. Afinal ele não morava tão longe assim, é de uma cidade da Grande SP.

O dono trouxe o micro em uma bolsa e o gabinete envolvido com plastibolha. Imaginou que fosse uma loja ou alguma oficina de manutenção. O local era neutro, embora fosse um dos ambientes de nosso trabalho. Eu havia chegado primeiro, vi o micro, ouvi novamente que foi um raio que provocou o defeito. Fiz cara feia ( de arrepio ), a namorada do cara respondeu "não faz essa cara!". O que eu poderia fazer? Ficar indiferente? Eu esperava o pior dos piores ( tipo HD furado, placa fumada, preta, etc ). Logo depois chegou meu amigo, conversamos e o proprietário retrucou com um tom de ameaça:"se vcs por acaso sumirem com meu micro, vou atrás!". Por pouco não respondemos: "se é assim, leve seu micro de volta!". Afinal de contas estávamos ali a pedidos de terceiros, sob indicação, e de um parente. Ele esperava o que? um papel com Ordem de Serviço? ou um Termo de Responsabilidade ou observações do Código de Defesa do Consumidor? Cada uma que temos que aturar.

Levamos o computador no nosso local de trabalho e desempacotamos e descobrimos o porquê do receio do cara, um micro relativamente caro, comprado no jp segundo a prima de meu amigo há cerca de um ano atrás. Segundo ela, o micro passou por avaliação em três lugares ( possivelmente não fossem lojas de manutenção de PCs, mas pessoas com nós, mortais adoradores de AMD, e provavelmente os outros que tentaram consertar estavam na mesma situaçã apesar de ser uma suposição muito ruim de minha parte hehe. O gabinete é todo estilizado, com luzinhas e coolers transparentes. Veja aqui uma foto dela:

Abrindo o gabinete percebemos o receio que passou antes de nós, é um Pentium 4 rápido, equipado com 1GB, motherboard ECS (éca!) 648FX-A

uma placa de vídeo ASUS V9520 HomeTheater

com entrada e saída de TV e vídeo em NTSC, na verdade uma GeForce FX5200 turbinada...com um nome diferente,uma Live! 5.1 e um HD de 200GB Seagate. Pode não ser top de linha hoje, nem talvez na época, mas é uma configuração boa para um Winuser mortal. Deixo para o leitor imaginar o preço desse bicho, que mesmo no jp não deve ter sido barato.

Ligamos o micro, o LEDzinho interno acendeu, mas nada de ligar no botão de power, nem cooler, nem piu, nem beep, nada.
Começamos testando as placas de vídeo, de áudio e as memórias. Percebemos que não havia nada de errado nelas. Testamos a fonte inclusive, mas nada nele, também estava normal. Sobrou o processador e a mo bo.

Não tínhamos mobos Pentium para testar, nem processadores P4. E nenhum conhecido próximo que se dispusesse a testar para nós, coisa arriscada claro, quem em sã consciência deixaria usar uma placa funcional para testar? Tivemos que apelar, a loja onde meu amigo costuma comprar hardware e de sua confiança.Fomos lá, o papo rolou solto ( para descontrair e ver se ele nos faria o favor de testar para nós. Após três horas de espera ( tratando do HD defeituoso dele inclusive, e esperando os outros compradores ) ele quebrou nosso galho. Levamos para a ala técnica e nada do micro "subir" (funcionar ou ligar). Cogitamos a BIOS corrompida, ele chegou a regravar ( de graça - claro que cobraria algo se adiantasse ) mas não resolveu. O dono da loja deixou pegarmos uma placa-mãe para testarmos o processador, e pimba, funcionou. Ainda bem que ele não tinha ido pro beleléu.

Decidimos trocá-la pela essa mobo mesmo, a ASUS P4P800-X


Passamos o orçamento para o proprietário, que ficou de consultar os pais acho.
E ontem pegamos a placa na loja. Remontamos o micro funcionou de primeira ( fez beep ), liguei o monitor e coloquei o CD do KuruminLinux para teste o PC ainda está sem HD, onde precisamos fazer uma cópia dos documentos e fazer cópia de restauração. É grandinho, mas pelo menos estava quase vazio...

Aprendi a manusear um Pentium4, retirar o cooler ( que s�o diferentes dos Athlons normais, mas parecidos com os Athlon64 ). Estou rodando dnetc e para minha decepção está fazendo 12.5 Mnodes/s, eu esperava mais que isso. Meu Athlon 2400+ faz 17 Mnodes/s do OGR-25. E um Athlon 1000 fazia 7 Mnodes/s, Então o P4 faz o mesmo que um Athlon de metade do valor PR? Porque se levar em consideração o clock real, ficaria pior, o PR é maior. Que lástima para um P4 3.4GHz Northwood, com 1GB dual channel. Isso no Linux, possivelmente no WindowsXP teria um desempenho próximo e provavelmente levemente inferior. Antes que alguém alegue que ele esteja underclockado por aquecimento, eu botei o dedo no cooler ( está com gabinete aberto ) e nem chegou a queimar, ou seja não passa dos 40 C no cooler, e provavelmente o Pentium4 não esteja muito acima disso, talvez uns 50-55 C.

Muito bom ter mexido num Pentium4. Apesar dos pesares. O que fica é o aprendizado. Falta ainda eu ver como ficaria com o rescurso HT, não sei se esse P4 tem, se tiver, minha decepção só aumentaria, hehehe.

Montei esse micro essa noite, com uma baita dor-de-cabeça por causa da comida que comi (gordurosa) no jantar. Mas como eu estava me divertindo, consegui fazer na boa. Falta a parte chata e provavelmente monótona, instalar WindowsXP e Office....irga.

domingo, junho 12, 2005

Athlons que Ressucitam


Há cerca de oito meses atrás peguei um computador da namorada do meu irmão para arrumar, novembro do ano passado. Não estava funcionando segundo ela pela descrição feita pelo meu irmão. Falei para trazer para eu dar uma olhada, mal sabia eu na encrenca e do aprendizado que estaria por vir.

Ligando reparei que a IDE estava desabilitado na BIOS, por isso o micro não entrava no Windows. Modifiquei e voltou a funcionar normalmente. O micro é um Athlon 1GHz.
Resolvi fazer um teste com uma outra placa-mãe que eu tinha para fazer uma atualização de BIOS, uma MSI K7T266Pro2-RU. Percebi que não funcionou. Ele tem um sistema de diagnóstico via quatro LEDs. Todos ficaram vermelhos, indicando problema no processador. Suei frio, porque quando o instalei, o gabinete apertado me obrigou a deslocar levemente o cooler, hoje sei que isso é uma coisa que não se deve fazer, mas como na época eu quase nunca havia manuseado um athlon ( minha única experiência se resumia em uma troca de cooler do athlon 2400+ do meu irmão ), pensei que fosse um procedimento inofensivo.
Bom, voltando, tremi na espinha, botei o Athlon 1000 de volta para a mobo original, um PCChips M817, tocou um mooonte de beeps. Tremi mais ainda. Limpei o athlon para poder observar se algum dano no core e vi que os cantos e uma parte de sua aresta estavam lascados, sem pedaço. Pensei: "xiiiii, estraguei". O deslocamento do cooler provavelmente danificou os cantos, imaginei. Eu tinha um dinheirinho, resolvi comprar outro Athlon em algum leilão como o Mercadolivre ou arremate. Acabei encontrando um Athlon 900MHz no arremate por um preço razoável. Chegou dali uma semana. Botei no M817 da namorada do meu irmão e os mesmos beeps. Fiquei com muita raiva, pensei que comprei gato por lebre: um athlon com problema vendido com preço de um funcionando.

Passaram-se oito meses, nesse meio tempo, mexia e nada vez ou outra. Eu não me atreveria a testar com o Athlon 2400+ para correr mais riscos, por isso fiquei todo esse tempo com o Athlon 1000 parado ( para variar no meu museu de CIs ) e o Athlon 900 ficou na M817. Nesse último mês "ganhei" uma placa-mãe supostamente com defeito ( o dono deixou escapar a chave de fenda do cooler e acertou uma trilha e de raiva quis jogar fora, eu peguei), dele também ganhei uma ECS K7SEM. Com três placas-mãe (K7SEM, K7T266Pro2-RU e K7S5A e a mortífera M817) à mão e supostamente nenhum processador sobrando, resolvi testar, nem que fosse para ouvir beeps com o Athlon 900. E qual não foi minha surpresa que a K7S5A bootou e mostrou a tela de POST reclamando que não tinha teclado nem onde fazer boot, e pensei:"não é possível que o processador tenha voltado a viver. Eu o retirei do K7S5A e botei de volta na mortal M817 ( a da namorada do meu irmão ). Eu instalei tudo de volta e comecei a instalar WindowsXP e OfficeXP, até o momento que resolvi instalar um RTL8139 que por coincidência ou não, fez o M817 voltar com a mesma sequência de beeps indicando processador defeituoso. Pensei:"Justo depois de 2h instalando todas essas tralhas? Que droga!".
Fiquei imaginando que fosse algum mau contato, etc. Até que peguei o Athlon 1000 que tinha ficado no meu museu de CIs antigos e botei ela no K7SEM ( que não tinha testado ainda ). E para a minha surpresa, também estava funcionando.
Então caiu a ficha, a "M817 killer" estava meio que matando temporariamente qualquer athlon que nela fosse utilizado. Não sei exatamente a causa, talvez voltagem incorreta, sei lá.
Coloquei esse Athlon 1000 no K7SEM e recomecei a maratona de instalação de WindowsXP e OfficeXP. E como previsto, rolou tudo bem, deixei muitas horas rodando distributed.net e sem problemas. O processador estava esquentando muito, resolvi instalar um cooler VCOM grande no lugar do original podrinho que estava, que está mais para cooler K6-2 do que para Athlon. Sofri um pouco para encontrar o driver da placa de modem, mas encontrei. Esse modem não tinha descrição nem o número FCC para ajudar, mas o CI principal ( o maior deles ) estava escrito "Ambient". Fui no Google, e botei "Ambient modem" retornando modem intel com o código do CI. Instalei e ainda falta fazer o teste com linha telefônica. Enfim, o micro está pronto para o meu irmão devolver para a dona original.
Disse para meu amigo que a "porrada" com chave de fenda na trilha apenas afundou e que o mesmo ainda funcionava. Cheguei a raspar a trilha com uma chavinha para ver e testar com um multímetro, e estava normal. E o desgraçado PEDIU A de volta. Bom, como sou um bom amigo, e por outros motivos, aceitei devolvê-lo, enchi muito o saco dele, mas devolvi. Afinal, ele precisa muito mais de uma placa de reserva que eu, ele só tem o micro dele, eu tenho dois aqui. E apesar que ele vá deixá-lo encostado, fica para testes de hardware, afinal ele já tinha me "presenteado" com a K7SEM funcional.

Não posso afirmar que o problema que passei como algo que ocorra com os outros Athlons e mobos, entretanto constitui-se numa possibilidade, nunca encontrei relatos parecidos com o meu, não fiz busca exaustiva nos fóruns de hardware ainda, nem sei se terei paciência, mas para quem mexe com hardware, fica a dica, do athlon que morre mas pode voltar a viver.

Bom, logo logo terei meu Athlon 900MHz funcionando no lugar desse K6-2 lerdo, preciso comprar uma fonte nova ( não vou economizar nesse quesito ) e uma memória DDR 256 ou 512MB.
Ainda vou demorar um pouco....vida sem muito dinheiro é complicado heheh.